To use the Papertrail app you must have an active account with us, and your device needs to be running at least iOS 8 or Android 4.1. 

If you are a new user and have not got an earlier version of the app on your device:

  1. Log in on to the App / Play Store
  2. Search for "Papertrail"
  3. Download the app

OR simply click on the button below:


The current version of the app is 2.13.1. If you are an existing user with an old version of the app, please follow these steps:

  1. Log in to the existing app on your device
  2. Carry out a sync to ensure all outstanding inspections, notes or images from the device are uploaded to your web app
  3. Log out of the app
  4. Delete the app from your device
  5. Download the new app as per the instructions above
  6. You should now be able to open our newest app version, log in and continue to use as usual.

See related articles:

Still can't find the answer you need? We'd love to help!
Contact our Customer Support Team via the chat button in the lower right corner of the screen, on +44 (0)1248 791270 or at support@papertrail.io

Did this answer your question?